Secure Certificate Issue
Incident Report for OMNILERT
Resolved
This issue has been resolved as the expired certificates have all been updated.
Posted Feb 28, 2020 - 08:23 EST
Investigating
Omnilert engineers are currently investigating issues with the certificate for the Omnilert admin portals.

Impact on Service: Browsers may indicate that the site is "not secure" due to the issue with the current certificate. (All functions still available, however.)
Posted Feb 28, 2020 - 08:04 EST