Possible SMS Receipt Delays
Incident Report for OMNILERT
Resolved
SMS Status Receipt delivery is again at full capacity.
Posted over 1 year ago. Jun 17, 2016 - 17:08 EDT
Investigating
We are investigating possible delays in receiving of SMS Delivery Status Receipts.
Posted over 1 year ago. Jun 17, 2016 - 16:53 EDT